Download

Jokosher for Ubuntu


Jokosher 0.10.1 for Ubuntu 8.04 LTS (Hardy Heron)


Jokosher 0.10.1 for Ubuntu 8.10 (Intrepid Ibex)

To install jokosher manually on Interpid Ibex, use Applications => Accesories => Terminal to issue command ‘sudo apt-get install jokosher‘ to install Jokosher. You will be asked to enter password you use to access your user account on system.

Older versions of Ubuntu aren’t supported because of old Gstreamer versions. However, you can try to install it from source, using Gstreamer CVS with depencies. Follow instructions on Jokosher documentation wiki here. Also you can see instructions how to install obsolete versions below in this page. Again, using such versions are neither supported or endorsed.

Installing Jokosher From Source

To get Jokosher source, you have two options. First, you can download lastest stable release tarball, decompress it and use it on your system. Use this option only if Jokosher is not packaged for your distribution:

Source Tarball Jokosher 0.10.1 (tar.gz)

If you plan to help in developing and testing Jokosher development version, you can check out Jokosher source from Launchpad Bazaar repository. Please follow instructions on Jokosher documentation wiki here.

General Installation Notes

Jokosher is written in Python, so it doesn’t require compiling to be used. In result, it should be relatively easy to get it running. However, it depends on Gstreamer “bloatin edge” features (as lastest gnonlin, various music file format support, and so on), so it requires up-to-date versions of Gstreamer libraries to be successfully used. First of all, be sure you use newest stable version of distribution of your choice available. Also, if encounter problems with playback and recording, please check if versions of Gstreamer packages shown below matches those on your system. If there is Gstreamer version mismatch or features missing, please submit bug reports to your distribution.
For additional depencies and instructions for installing Jokosher from source, see Jokosher documentation wiki Installation page.

Recommended versions of Gstreamer packages

  • GStreamer - 0.10.12 and newer
  • gstreamer-plugins-base - 0.10.12 and newer
  • gstreamer-plugins-good - 0.10.5 and newer
  • Gnonlin - 0.10.8 and newer
  • gstreamer-plugins-ugly - 0.10.5 and newer (optional)
  • gstreamer-plugins-bad - 0.10.4 and newer (optional)

Obsolete versions

Installing Jokosher 0.9 on Ubuntu 7.04 Feisty

To install Jokosher 0.9 on Feisty, you should first install an updated Gnonlin package (version 0.10.8). Choose which package you need (if unsure, pick the i386 package):

Download the package and it should be loaded into GDebi and install automatically. You should then download this Feisty package and it will install in the same way. Jokosher is now installed.

Installing Jokosher 0.9 on Ubuntu 7.10 Gutsy

Jokosher 0.9 is available for installation in Gutsy. Use Applications->Add/Remove to install it.

Installing Jokosher 0.9 on Fedora 7

Jokosher 0.9 is available for installation in Fedora 7. Use Applications->Add/Remove or yum to install it.

Installing Jokosher 0.9 on OpenSuse

Instructions for running the newest version of Jokosher on OpenSuse are available on the wiki.

Previous Jokosher versions

The installation instructions for Jokosher 0.1 are still available should you need them (but you shouldn’t).